Export limit exceeded: 16136 CVEs match your query. Please refine your search to export 10,000 CVEs or fewer.

Search

Search Results (16136 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2023-39128 1 Gnu 1 Gdb 2026-10-15 5.5 Medium
GNU gdb (GDB) 13.0.50.20220805-git was discovered to contain a stack overflow via the function ada_decode at /gdb/ada-lang.c.
CVE-2023-36660 1 Nettle Project 1 Nettle 2026-10-15 9.8 Critical
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
CVE-2023-35001 5 Debian, Fedoraproject, Linux and 2 more 15 Debian Linux, Fedora, Linux Kernel and 12 more 2026-10-15 7.8 High
Linux Kernel nftables Out-Of-Bounds Read/Write Vulnerability; nft_byteorder poorly handled vm register contents when CAP_NET_ADMIN is in any user or network namespace
CVE-2023-34319 3 Debian, Linux, Xen 3 Debian Linux, Linux Kernel, Xen 2026-10-15 7.8 High
The fix for XSA-423 added logic to Linux'es netback driver to deal with a frontend splitting a packet in a way such that not all of the headers would come in one piece. Unfortunately the logic introduced there didn't account for the extreme case of the entire packet being split into as many pieces as permitted by the protocol, yet still being smaller than the area that's specially dealt with to keep all (possible) headers together. Such an unusual packet would therefore trigger a buffer overrun in the driver.
CVE-2023-32643 1 Gnome 1 Glib 2026-10-15 5.3 Medium
A flaw was found in GLib. The GVariant deserialization code is vulnerable to a heap buffer overflow introduced by the fix for CVE-2023-32665. This bug does not affect any released version of GLib, but does affect GLib distributors who followed the guidance of GLib developers to backport the initial fix for CVE-2023-32665.
CVE-2026-16170 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 7.5 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to cause a denial of service due to a heap buffer overflow.
CVE-2026-16178 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 7.5 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to cause a denial of service due to improper input validation.
CVE-2026-16340 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 9.8 Critical
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to execute arbitrary code due to an out-of-bounds write in the RFC2047 encoded-word parser.
CVE-2026-14991 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 9.8 Critical
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 is vulnerable to a buffer overflow, caused by improper bounds checking. A local user could overflow the buffer and execute arbitrary code on the system.
CVE-2026-15762 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 9.8 Critical
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to execute arbitrary code due to an out-of-bounds write.
CVE-2026-15784 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 8.1 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to execute arbitrary code due to an out-of-bounds write.
CVE-2026-15819 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 7.5 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to cause a denial of service due to out-of-bounds memory access caused by a strict-weak-ordering violation in a sorting comparator.
CVE-2026-15824 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 8.2 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to cause a denial of service due to a heap-based buffer overflow.
CVE-2026-16159 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 8.6 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to obtain sensitive information and cause a denial of service due to an out-of-bounds write.
CVE-2026-16163 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 8.6 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to cause memory corruption due to an out-of-bounds write.
CVE-2026-16164 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-15 7.5 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to cause a denial of service due to a buffer overflow.
CVE-2026-16167 1 Ibm 5 Datapower Gateway, Datapower Gateway 1050, Datapower Gateway 1060 and 2 more 2026-10-14 7.5 High
IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to cause a denial of service due to improper bounds checking.
CVE-2026-85440 1 Themoos 1 Core-moos 2026-10-14 9.8 Critical
MOOS core-moos through 10.4.0 contains a pre-authentication heap overflow vulnerability in MOOSCommPkt packet handling that allows remote attackers to write arbitrary data by declaring a negative packet length. Attackers can exploit the signed integer check in InflateTo() and negative size conversion in recv() to overflow a four-byte heap buffer during the HandShake phase before authentication.
CVE-2026-85437 2 Mit, Moos-ivp 2 Moos-ivp, Moos-ivp 2026-10-14 9.8 Critical
MOOS-IvP through 24.8.1 contains multiple buffer overflow vulnerabilities in IvP function string decoders that trust attacker-controlled length fields without validation. Attackers can craft malicious encoded strings with mismatched declared and actual field lengths to overflow heap and stack buffers, potentially achieving remote code execution through MOOS variables or alog files.
CVE-2023-31436 2 Linux, Redhat 9 Linux Kernel, Enterprise Linux, Rhel Aus and 6 more 2026-10-14 7.8 High
qfq_change_class in net/sched/sch_qfq.c in the Linux kernel before 6.2.13 allows an out-of-bounds write because lmax can exceed QFQ_MIN_LMAX.